Welcome, Guest
Username: Password: Remember me
*****PLEASE, CHECK ALL PREVIOUS TOPICS, BEFORE CREATING A NEW ONE! DUPLICATED TOPICS WILL BE DELETED!*****

TOPIC: E-Coder on Linux

E-Coder on Linux 05 Aug 2018 11:03 #1

  • May
  • May's Avatar
  • OFFLINE
  • Posts: 4
Hi All,

I've recently transitioned my SunSDR2 Pro setup to Linux - Ubuntu 18.04 LTS.

I'm having trouble getting the E-Coder to work.

Ubuntu recognises it:

$ dmesg | grep E-Coder
[ 2.894774] usb 1-8.3: Product: E-Coder panel
[ 3.492192] hid-generic 0003:1FC9:0003.0008: hiddev3,hidraw5: USB HID v1.00 Device [EXPERT-ELECT E-Coder panel ] on usb-0000:00:14.0-8.3/input0

But ExpertSDR2 v1.2.0 doesn't. The "Panel" tab is there, and I can set the button functions, but nothing works..

Is there anything specific required to setup the E-Coder with Linux / Ubuntu ?

Regards, Peter.
The administrator has disabled public write access.

E-Coder on Linux 12 Dec 2018 14:34 #2

  • May
  • May's Avatar
  • OFFLINE
  • Posts: 4
Bump topic - still no joy getting it to work / no repsonse.... help ???
The administrator has disabled public write access.

E-Coder on Linux 15 Jan 2019 10:54 #3

  • S58WW
  • S58WW's Avatar
  • OFFLINE
  • A half-truth is the most cowardly of lies.
  • Posts: 149
  • Thank you received: 40
Hello all!
Dear admins!

I would also like to know the reason why E-coder (s) is not working on UBUNTU?

UBUNTU or ESDR2 problem?

It is not life and death emergency, but please let us know! (I have dual boot W10/UBUNTU PC so.... :D :D )

thank you in advance! заранее спасибо!
73 Pibo S58WW
2 X SUNSDR2pro
Main shack PC:
AMD RYZEN 7 2700 (8 cores ; 16 threads) 32 GB RAM
on Gigabyte Aorus Elite B450 with 1TB and 250 GB INTEL NVMe M.2
NVIDIA GeForce GTX 1660 SUPER
The administrator has disabled public write access.

E-Coder on Linux 15 Jan 2019 11:09 #4

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1091
  • Thank you received: 534
Hi, Pibo.
By default Linux does not allow access to USB devices, to use them (including E-Coder) you need to enter the following lines when the system starts:
sudo chmod 664 /dev/hidraw*
sudo chgrp plugdev /dev/hidraw*
Роман, Roman
Expert Electronics
The administrator has disabled public write access.
The following user(s) said Thank You: S58WW

E-Coder on Linux 15 Jan 2019 11:26 #5

  • S58WW
  • S58WW's Avatar
  • OFFLINE
  • A half-truth is the most cowardly of lies.
  • Posts: 149
  • Thank you received: 40
Great support Rome!

I will try and report ...

HNY and al the best!
73 Pibo S58WW
2 X SUNSDR2pro
Main shack PC:
AMD RYZEN 7 2700 (8 cores ; 16 threads) 32 GB RAM
on Gigabyte Aorus Elite B450 with 1TB and 250 GB INTEL NVMe M.2
NVIDIA GeForce GTX 1660 SUPER
The administrator has disabled public write access.
The following user(s) said Thank You: Rome

E-Coder on Linux 15 Jan 2019 11:36 #6

  • S58WW
  • S58WW's Avatar
  • OFFLINE
  • A half-truth is the most cowardly of lies.
  • Posts: 149
  • Thank you received: 40
:D

WORKING!
I am impressed!
I always was sure that EXPERT ELECTRONICS is firm you can trust!

:hi:
73 Pibo S58WW
2 X SUNSDR2pro
Main shack PC:
AMD RYZEN 7 2700 (8 cores ; 16 threads) 32 GB RAM
on Gigabyte Aorus Elite B450 with 1TB and 250 GB INTEL NVMe M.2
NVIDIA GeForce GTX 1660 SUPER
The administrator has disabled public write access.
The following user(s) said Thank You: Rome

E-Coder on Linux 23 Apr 2021 16:27 #7

  • OK1RR
  • OK1RR's Avatar
  • OFFLINE
  • CW forever!
  • Posts: 38
  • Thank you received: 17
Rome wrote:
Hi, Pibo.
By default Linux does not allow access to USB devices, to use them (including E-Coder) you need to enter the following lines when the system starts:
sudo chmod 664 /dev/hidraw*
sudo chgrp plugdev /dev/hidraw*

This is good solution and works ... until restart!

My solution is permanent, it is an udev entry. Copy the line
KERNEL=="hidraw*", SUBSYSTEM=="hidraw", MODE="0664", GROUP="plugdev"
and save it to file
99-hidraw-permissions.rules
This file must be located in
/etc/udev/rules.d/
Ensure that you are member of the "plugdev" group. Most users already are.
73,
Martin, OK1RR
The administrator has disabled public write access.
The following user(s) said Thank You: S58WW, Rome, LB2EG

E-Coder on Linux 09 Jun 2021 01:40 #8

We both hit on the same solution, though with a difference. My UDEV rule identifies the /dev/hidraw device that the E-Coder is on, and sets group and permissions only for that one. It might not make any difference, but I feel more comfortable not changing them for other devices. Here's my rule:

SUBSYSTEM=="hidraw", ATTRS{idProduct}=="0003", ATTRS{idVendor}=="1fc9",
SYMLINK+="expert_ecoder", GROUP="plugdev", MODE="0664"

73,
Russ, KC7MM
The administrator has disabled public write access.
Time to create page: 0.063 seconds