Welcome, Guest
Username: Password: Remember me

TOPIC: Refuse to change Mode

Refuse to change Mode 02 Mar 2022 20:59 #1

  • Patrice
  • Patrice's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 1
Hello
Last version Expert3 0.12 and last firmware

While running JTDX with TCI interface set, it is impossible change mode. It is necessary to close JTDX
Procedures
- Case 1 : Start JTDX, set a band/mode (20m/FT8 14074). Them try to select CW : it will briefly switch to CW them back to FT8
closing JTDX, them the mode can be changed to any

- Case 2: Select USB in ExpertSDR3, them qrg 21074. Start JTDX. Using ExpertSDR3, select FT8 : The mode will briefly switch to FT8 them back to USB.
It is possible to get FT8 mode by using JTDX and set 15m/21074

It was not the case with previous version 0.11.
currently, it means that JTDX has to be closed if you want to work in another mode (CW./SSB) for a "quick qso", and them restart JTDX

any one having same behavior?
73 - P@t F6GCP
The administrator has disabled public write access.

Refuse to change Mode 03 Mar 2022 07:14 #2

  • F1DJY
  • F1DJY's Avatar
  • OFFLINE
  • Posts: 62
  • Thank you received: 20
I saw instabilities like what you describe with the jTDX 1.58 version. And I confirm that indeed it is JTDX which imposes the mode. For my account I use the latest version of MSHV and everything works fine. It's esdr3 that chooses the mode, you can use FT8 or USB. 73 Jean-marie F1DJY
The administrator has disabled public write access.
The following user(s) said Thank You: N8SDR

Refuse to change Mode 03 Mar 2022 07:23 #3

  • F1DJY
  • F1DJY's Avatar
  • OFFLINE
  • Posts: 62
  • Thank you received: 20
Another big practical advantage of MSHV compared to JTDX is that there is no need to lower the AGC level in ESDR3 so as not to saturate with a too high TCI gain, because you can define the receive level in mSHV which avoids having to switch from auto AGC to manual AGC by switching from SSB to FT8
The administrator has disabled public write access.
The following user(s) said Thank You: N8SDR

Refuse to change Mode 03 Mar 2022 08:19 #4

  • G4ENZ
  • G4ENZ's Avatar
  • OFFLINE
  • Posts: 36
  • Thank you received: 11
Hi Patrice,

Have you thought of using RX2? I often run CW or SSB on a band in RX1 and have RX2 with MSHV or JTDX working on RX2. Best of both worlds :D

73 Martin
The administrator has disabled public write access.

Refuse to change Mode 03 Mar 2022 13:35 #5

  • N8SDR
  • N8SDR's Avatar
  • OFFLINE
  • Posts: 609
  • Thank you received: 289
Or even run TWO instances of MSHV one on RX1 and other on RX2 and use different Digital Modes- FT8 say of 20/40 and Meteor scatter on 6M

But as someone pointed out the problem isn't V3 the problem is MODE Control in JTDX
73 Rick
The administrator has disabled public write access.

Refuse to change Mode 03 Mar 2022 18:56 #6

  • OK2WY
  • OK2WY's Avatar
  • OFFLINE
  • Posts: 13
  • Thank you received: 4
It works the same way in EESDR2.

Simply enter the config menu in JTDX, folder RADIO and set mode to "none". Then you can choose mode manually even if JTDX is running.
The administrator has disabled public write access.

Refuse to change Mode 04 Mar 2022 19:11 #7

  • Patrice
  • Patrice's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 1
Hi
thanks for all answers. I will have a look
I notice that a new JTDX version 1.59 was released in past days, and in the notes, there are plenty of changes to support TCI interface. So potentially some fixes.

I am new on ExpertSDR so learning curve,and I am just running Expert3 so beta versions
And also, just RX1 so far (more than 40 years with classic radio... a big change, but very nice for CW/SSB!...)

73 es DX - P@t F6GCP
The administrator has disabled public write access.

Refuse to change Mode 05 Mar 2022 22:14 #8

  • Patrice
  • Patrice's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 1
Hi,
Even with JTDX 2.2.159, JTDX forces Mode and Split via TCI to ExpertSDR software. So JTDX is not usable using TCI
And the number of lines "CW server" / "DIGU client" is impressive...
So JTDX is not usable using TCI. I will see how to report to JTDX group.
Going back to COM port and VAC (as before)
73 - P@t


23-02-52:794 server: app_focus:true;
23-02-56:996 server: modulation:0,CW;
23-02-56:996 server: drive:0,0;
23-02-56:996 server: rx_filter_band:0,-300,300;
23-02-56:996 server: modulation:0,CW;
23-02-56:996 server: drive:0,0;
23-02-56:996 server: rx_filter_band:0,-300,300;
23-02-56:996 server: modulation:0,CW;
23-02-56:996 server: drive:0,0;
23-02-56:996 server: rx_filter_band:0,-300,300;
23-02-56:996 client: modulation:0,digu;
23-02-56:996 server: modulation:0,CW;
23-02-56:997 client: modulation:0,digu;
23-02-56:997 server: modulation:0,CW; ... and hundreds line like these.
The administrator has disabled public write access.

Refuse to change Mode 06 Mar 2022 12:34 #9

  • danielwee
  • danielwee's Avatar
  • OFFLINE
  • Posts: 209
  • Thank you received: 29
I use JTDX 159 (Windows 10 64-bit) with EESDR3 without issues. What exactly are you seeing happen? What OS version are you using?
The administrator has disabled public write access.

Refuse to change Mode 07 Mar 2022 07:56 #10

  • Patrice
  • Patrice's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 1
Hi
I am on Win10/64 last version. As reported by others, it is JTDX issue : it forces to digimode even if you select CW (or SSB..) in ExpertSDR (using TCI).
Reconfiguration on JTDX from TCI to DXLab Commander to yet perform, as it was previous configuration (I have to reinstall VAC).
73 - P@t F6GCP
The administrator has disabled public write access.

Refuse to change Mode 07 Mar 2022 10:15 #11

  • OK2WY
  • OK2WY's Avatar
  • OFFLINE
  • Posts: 13
  • Thank you received: 4
Patrice wrote:
Hi
I am on Win10/64 last version. As reported by others, it is JTDX issue : it forces to digimode even if you select CW (or SSB..) in ExpertSDR (using TCI).
Reconfiguration on JTDX from TCI to DXLab Commander to yet perform, as it was previous configuration (I have to reinstall VAC).
73 - P@t F6GCP

It is not issue, it is feature easily solvable in JTDX setup as i wrote before. See screenshot and set MODE in JTDX setup:

jtdxsetup.png
The administrator has disabled public write access.
Time to create page: 0.096 seconds