Welcome, Guest
Username: Password: Remember me

TOPIC: Installing on Linux

Installing on Linux 27 Apr 2022 16:09 #1

  • ww1ss
  • ww1ss's Avatar
  • OFFLINE
  • Posts: 21
  • Thank you received: 6
So I know nothing about Linux. Trying to install ExpertSDR 3 on my Pi with Ubuntu. Wgen I try to execute the sh file I get error on line 11 "no such file or directory. I downloaded it to my Ubuntu downloads directory then extracted the files.
What am I doing wrong as I no nothing about Linux . . . Seems real difficult here.
The administrator has disabled public write access.

Installing on Linux 27 Apr 2022 19:17 #2

  • ww1ss
  • ww1ss's Avatar
  • OFFLINE
  • Posts: 21
  • Thank you received: 6
Fixed directory error . . . Now getting . . . cannot execute binary file: EXEC format error
The administrator has disabled public write access.

Installing on Linux 28 Apr 2022 06:08 #3

  • hari
  • hari's Avatar
  • OFFLINE
  • Posts: 26
  • Thank you received: 8
The ExpertSDR 3 Desktop Client software is compiled for X86_64 systems. You cannot run that on ARM processors like the Raspberry PI.
vy 73 OE6HKE
The administrator has disabled public write access.
The following user(s) said Thank You: g7mns

Installing on Linux 28 Apr 2022 10:31 #4

  • ww1ss
  • ww1ss's Avatar
  • OFFLINE
  • Posts: 21
  • Thank you received: 6
Oh . . . So you can run it with a Linux OS or Mac OS but the Linux basically has to run on a PC. Got it.
Last Edit: 28 Apr 2022 10:36 by ww1ss.
The administrator has disabled public write access.

Installing on Linux 28 Apr 2022 10:36 #5

  • hari
  • hari's Avatar
  • OFFLINE
  • Posts: 26
  • Thank you received: 8
The Linux version of ExpertSDR3 is compiled for X86_64 processor architectures. You're trying to run on a non-X86_64 platform (ARM). That's why you do see an exec format error. A X86_64 Linux binary cannot be exectuted on ARM (without additional translation layers like qemu, etc, but that's going to far here)
$ file ExpertSDR3 
ExpertSDR3: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=df6ee724bcbdb21e0dc36a10783ac1064470a014, for GNU/Linux 3.2.0, not stripped
vy 73 OE6HKE
Last Edit: 28 Apr 2022 10:59 by hari. Reason: add 'file' output
The administrator has disabled public write access.
Time to create page: 0.079 seconds