Welcome, Guest
Username: Password: Remember me

TOPIC: ExpertSDR source

ExpertSDR source 06 Apr 2015 20:54 #16

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Exist a solution remove cblas from CMakeLists.txt and run once again
cmake
and
make
because this CMakeLists.txt I used in manjaro linux and here I need because is difference between lib fftw3 from ubuntu and manjaro.
The administrator has disabled public write access.

ExpertSDR source 06 Apr 2015 21:02 #17

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hello,
I'm sorry , I feel really bad about this and I must keep asking you for assistance but things keep failing.

I found a package that satisfies "cblas" and the build no longer fails on that. However, now the build fails with:
[ 1%] Automatic moc for target expertsdr
[ 1%] Built target expertsdr_automoc
Linking CXX executable expertsdr
//usr/local/lib/libDttSP.so: undefined reference to `timeKillEvent'
collect2: ld returned 1 exit status
CMakeFiles/expertsdr.dir/build.make:1479: recipe for target 'expertsdr' failed
make[2]: *** [expertsdr] Error 1
CMakeFiles/Makefile2:60: recipe for target 'CMakeFiles/expertsdr.dir/all' failed
make[1]: *** [CMakeFiles/expertsdr.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2
ron@squireoaksfarm-radio ~/src/OpenExpertSDR/build $


I am using the libDttSP from github.com/wd8rde/libDttSP

Should I use your libDttSP library?

73,
Ron / W4MMP
The administrator has disabled public write access.

ExpertSDR source 06 Apr 2015 21:06 #18

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Remove also DttSP from CMakeLists.txt and rerun cmake and make.
Now I tested in ubuntu you need this lib -lDttSP -lGLU -lportaudio -lpthread -lm -lfftw3f -lm
To compile I use qtcreator what use qmake. Sorry but arch linux is different comparative with ubuntu.

LE> No use Robert library because at mine you not have all modification.
LLE> In .pro I have this flag
QMAKE_CXXFLAGS += -Wno-unused-function
and in CMakeLists.txt is not.
Last Edit: 06 Apr 2015 21:17 by Tanasa.
The administrator has disabled public write access.

ExpertSDR source 06 Apr 2015 21:24 #19

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hi Tanasa,

OK, thanks. I am a bit confused. Do I remove DttSP from the list of libraries? You say remove DttSP but then you say
"you need this lib -lDttSP -lGLU -lportaudio -lpthread -lm -lfftw3f -lm". Do I need DttSP? (or not need DttSP).

73,
Ron / W4MMP
The administrator has disabled public write access.

ExpertSDR source 06 Apr 2015 21:25 #20

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Remove DttSP from CMakeLists.txt.
The administrator has disabled public write access.

ExpertSDR source 06 Apr 2015 22:34 #21

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Thanks again. OK, I will do that.
73,
Ron / W4MMP
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 00:41 #22

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hello Tanasa,

Success!!. OpenExpertSDR has successfully built and installed. But there is just hopefully one more issue to resolve.
When I run ExpertSDR the following error occurs:

ron@squireoaksfarm-radio ~ $ echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games:/usr/local/Qt-5.4.1/lib:/usr/local/Qt-5.4.1/bin:/usr/local/Qt-5.4.1/include:/usr/local/Qt-5.4.1/plugins:.

ron@squireoaksfarm-radio ~ $ expertsdr
expertsdr: error while loading shared libraries: libQt5OpenGL.so.5: cannot open shared object file: No such file or directory

ron@squireoaksfarm-radio ~ $ cd /usr/local/Qt-5.4.1

ron@squireoaksfarm-radio /usr/local/Qt-5.4.1 $ cd lib

ron@squireoaksfarm-radio /usr/local/Qt-5.4.1/lib $ ll libQt5OpenGL.so.5*
lrwxrwxrwx 1 root staff 21 Apr 6 11:04 libQt5OpenGL.so.5 -> libQt5OpenGL.so.5.4.1
lrwxrwxrwx 1 root staff 21 Apr 6 11:04 libQt5OpenGL.so.5.4 -> libQt5OpenGL.so.5.4.1
-rwxr-xr-x 1 root staff 281K Apr 6 11:04 libQt5OpenGL.so.5.4.1
ron@squireoaksfarm-radio /usr/local/Qt-5.4.1/lib $

As you can see the Qt libraries are there. For some reason ExpertSDR believes the library is not available. Is there a shell export variable that needs to be defined?
73
Ron / W4MMP
Last Edit: 07 Apr 2015 00:43 by W4MMP. Reason: added a question
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 06:08 #23

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Try
sudo ldconfig -p | grep libQt5OpenGL.so.5
If not have a answer add in /etc/ld.so.conf the line /usr/local/Qt-5.4.1/lib and then run
sudo ldconfig
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 14:53 #24

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hello Tanasa,
Thank you again so very much for your help. It is getting closer and closer to working. :wall: Correcting the library issue has allowed ExpertSDR to run. There are now a couple of issues that needed to be addressed. First pulse audio is not functioning correctly. However I will look into that and I know I can resolve that issue. The second is the panel that displays the graphical information will not start/display. I have attached a screen shot. I have also attached a file with the ExpertSDR output when it starts.

73,
Ron / W4MMP
Screenshot2015-04-0710.37.49_cr.jpg
Attachments:
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 16:18 #25

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Also at my odroid U2 do not wish to load DttSP lib so I can to tell if work in my arm platform
At you is OpenGL problem>
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
For unreferencing with timer is necessary -lrt in .pro file and rt in CMakeLists.txt
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 17:02 #26

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
I fixed modified the source to take the lib from /usr/local/lib, and start correctly I have screen complet but the opengl speed is very slow and also the sound is slow, the cpu is 26%.
For opengl I found this solution github.com/lunixbochs/glshim try you may work for you also I start to try.
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 19:53 #27

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
For me not help this lib github.com/lunixbochs/glshim
The administrator has disabled public write access.

ExpertSDR source 07 Apr 2015 21:22 #28

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hi Tanasa,
Source I download the repository source and rebuild?

73,
Ron / W4MMP
The administrator has disabled public write access.

ExpertSDR source 08 Apr 2015 02:54 #29

  • W4MMP
  • W4MMP's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
Hi Tanasa,
Well, I don't have the knowledge necessary to make this work. I have no idea what you want :
"Also at my odroid U2 do not wish to load DttSP lib so I can to tell if work in my arm platform
At you is OpenGL problem>
QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
For unreferencing with timer is necessary -lrt in .pro file and rt in CMakeLists.txt "
What is rt?

I think I will give up on this, at least for the time being.

Thanks,
Ron
The administrator has disabled public write access.

ExpertSDR source 08 Apr 2015 08:00 #30

  • Tanasa
  • Tanasa's Avatar
  • OFFLINE
  • Posts: 14
  • Thank you received: 1
-lrt or rt was for this error
I found a package that satisfies "cblas" and the build no longer fails on that. However, now the build fails with:
[ 1%] Automatic moc for target expertsdr
[ 1%] Built target expertsdr_automoc
Linking CXX executable expertsdr
//usr/local/lib/libDttSP.so: undefined reference to `timeKillEvent'
collect2: ld returned 1 exit status
CMakeFiles/expertsdr.dir/build.make:1479: recipe for target 'expertsdr' failed
make[2]: *** [expertsdr] Error 1
CMakeFiles/Makefile2:60: recipe for target 'CMakeFiles/expertsdr.dir/all' failed
make[1]: *** [CMakeFiles/expertsdr.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2

Try to use your device not remote maybe the client remote not send you correct opengl window.
Test with glsxgear.
I not want something but is diference from opengl and opengl es and also my odroid u2 is different by your device and have another problems but now the expertsdr for linux is in progres is not finished and we have in plus problems comparative with desktop pc.
The administrator has disabled public write access.
Time to create page: 0.080 seconds