Welcome, Guest
Username: Password: Remember me

TOPIC: Amplifier connection problems

Amplifier connection problems 28 May 2022 13:49 #1

I just got a SunSDR2 DX and so far it is excellent.
I do have one problem.....connecting and using an amplifier.
I connected my one amplifier...a Heathkit SB220 with an RCA cable from the ALC jack in the back of the radio to an Ameritron ARB 704 amp relay. The 704 transmitting light stays on indicating there is some kind of voltage even when not transmitting. I then tried just a straight RCA cable from the ALC of the radio to the Heathkit. I noticed a continuous transmit problem while doing that.
I then noticed that when I turn the amp on, my receive on the radio drops a bit. Guessing it might be an amp problem, I then hooked up my Amp Supply LK800. Same problem. The transmit light on the Amp Supply amp stays lit just as the Heathkit amp shows it is being keyed on the Ameritron ARB 704.
The question I have is the instruction book says that amplifier damage can occur while using the ALC jack. I just put in an order for a cable that has the 15 pin connector to the external control jack and an RCA male plug at the other end. Will this cable and the use of the external control jack solve this problem? Is it a software situation where a change needs to be done in the options section? I read the instructions several times and it seems that very little is mentioned about hooking up and running an amplifier...especially an older amplifier.
HELP!!!!!!!
The administrator has disabled public write access.
Time to create page: 0.079 seconds