Welcome, Guest
Username: Password: Remember me

TOPIC: MB1 in remote mode

MB1 in remote mode 15 Aug 2016 14:17 #1

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Hi,

Is anyone among you has managed to control the MB1 from another PC on the LAN?
I would like to control the MB1 with my computer in my desk room but I'm unable to do it.

I make a bridge between USB LAN card of the MB1 ans the Ethernet card connected to my LAN as Vasily advised me and when I press "Search" in "Options --> Device" the MB1 at 192.168.158.200 so I press "Use" and I try to start the MB-1 with the power button on the top left of the desktop view of ExpertSDR2 software (view of ExpertSDR2 software must be switched to desktop view in this particular use) but starting of the MB1 fails and I get a "Can't connect MB1" message.

Note that when I make a bridge between the two LAN cards ExpertSDR2 software on the MB1 itself stops working and once the bridge is created if I try to start MB1 again I get the same message "Can't connect MB1" than on my desktop PC.

Perhaps there is something I forget in the procedure to get it work?

Many thanks in advance for your eventual help.
The administrator has disabled public write access.

MB1 in remote mode 15 Aug 2016 17:51 #2

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
After you have created the Network Bridge, did you then go to properties and give it an IP configuration?

As you can see, it works here.


Attachment Capture_2016-08-15.png not found

The administrator has disabled public write access.

MB1 in remote mode 15 Aug 2016 18:34 #3

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Hi Erik,

what do you mean when you write "did you then go to properties and give it an IP configuration?"

Concerning the bridge, it appears to be OK and I've given a static IP address to the network bridge to fit with my LAN.

The bridge seems OK as MB1 is seen by the distant computer as I've explained in my previous message.

The problem is that I can't connect the MB1 in despite it is seen on my desktop computer in another room with ExpertSDR2 softwre installed. The problem is that even can't connect t the MB1 on the MB1 itself. Once the bridge is done I'm not able to connect the MB1 anymore even on the MB1 itself.

By your side, can you connect connect the MB1 after you have created the bridge?

Edit: on your example I don't understand your bridge as only MB1 USB LAN is connected to the bridge. So I don't understand how your network bridge can work as MB1 seem not to be linked to your LAN via your TP-Link WiFI card or anything else.

According your particular bridge connection, are you able to see the MB1 on another computer on your LAN?
Last Edit: 15 Aug 2016 18:50 by f4bwj.
The administrator has disabled public write access.

MB1 in remote mode 15 Aug 2016 20:35 #4

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
Perhaps not the best picture I could have included. The Bridge is connected to the Internal MB1 LAN and the Ethernet port. I had shut down the remote computer as I needed its monitor to take the screen shot.

I think anyway you have done what I was asking about. When the Bridge is created, it doesn't have a valid IP address so you have to give it one. You say you have done that so that is fine. This has to be on the same subnet as the internal MB1 LAN. If you don't do that, you will not be able to connect to the MB1 either remotely or on the MB1 computer.

So you have internal MB1 LAN bridged to Ethernet. Now connect to remote computer. You will have that computer on a different subnet so in your router set up a static route to the destination network. Your router manual will explain how - it is simple but different for every router.

Alternatively put everything on the same subnet and then a static route is not necessary. But is has to be the MB1 subnet because it seems the MB1 internal LAN is locked to the 192.168.158.xxx subnet.

Finally, just to answer your last two questions:
yes I can connect to the MB1 after I have created the Bridge and after I have given it a valid IP address
yes I see the MB1 on the Ethernet connected 2nd computer after I have setup a static route to the MB1 network.

Probably Vassily has done this many times and will help you, maybe by TeamViewer session if you still are not clear about it.
The administrator has disabled public write access.

MB1 in remote mode 15 Aug 2016 21:09 #5

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Many thanks for your reply Erik,
concerning network configuration everything is Ok and as I've written when I click the "Search" button in Option Device on the distant computer in my desk room the MB1 is effectively found. But connection is impossible.

Concerning the impossibility to connect the MB1 on it self via its own ExpertSDR2 software I've progressed and now MB1 can be connected on the MB1 itself once network bridge has been created. In Internet Protocol Version 4 (IPv4) of the network bridge properties, I've configured "General" with a static IP, Subnet mask, Gateway, DNS with suitable parameters corresponding to my LAN and after I've gone to Advanced and I've added an IP address such as 192.168.158.1 corresponding to the IP domain of the USB card LAN of the MB1 in IP parameters tab.

After applying this change I can connect the MB1 with ExpertSDR2 software on itself but I still cannot connect it from my distant computer in despite it is still found via the "Search button" :(

Note that Vassily wrote me last week that he didn't try remote mode with the MB1 yet. Normally he should try during this week. i'm waiting for his results.
Last Edit: 15 Aug 2016 21:12 by f4bwj.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 06:16 #6

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
One thing I didn't say which I've just checked on: when you set up the static route in your router so that the remote computer sees the MB1 computer, you can have only one instance of ExpertSDR2 running - the one on the remote side, the host must not have it running. Otherwise the remote will find the MB1 but not connect. Probably you already knew but I thought I'd mention it in case.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 09:15 #7

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
No problem Erik I'am aware of that as it appearing logical for me .. ;)

Anyway, I've found how to get it work this morning.

In fact I just had to do exactly the same thing than on the MB1 on the distant computer: In Network properties of the Ethernet card of the distant computer I just add an IP address such as 192.168.158.2 in "Advanced" of "Internet Protocol Version 4 (IPv4)". :D
Now I can control the MB1 from my desk room computer. I can notice a very low latency, very interesting thing. ;)
Last Edit: 16 Aug 2016 09:17 by f4bwj.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 10:15 #8

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
Yes so your LAN is on the same subnet as I explained: "Alternatively put everything on the same subnet and then a static route is not necessary. But is has to be the MB1 subnet because it seems the MB1 internal LAN is locked to the 192.168.158.xxx subnet."

For anyone reading this who has the remote computer on a different subnet , you will need to setup a static route. For example my remote computer is on 192.168.0.100 because my modem/router gateway is 192.168.0.1 - I have other computers, 2 music servers and a Network Attached Storage device in the house all on that network so I didn't want to change it all. Then the static routing allows the 192.168.0.xxx network to connect (route) to the 192.168.158.xxx network.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 11:56 #9

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Ok, for my part, my LAN with the router and my computers are in the address range of 192.168.0.0 to 192.168.0.255.

I cannot change this because I'm in the same case than you with music servers, computers dedicated for my HIFI installation, computer for mu work etc... I could change the IP of my router to something like 192.168.158.1 to fit with the net ID of the MB1 but I would have too many IP addresses to change after on too many devices.

Finally it's easier to add an IP address in advanced settings of "Internet Protocol Version 4 (IPv4)" corresponding to the net ID of the MB1 in the Networking settings of the Ethernet card of the computers that will be used for control the MB1.
Last Edit: 16 Aug 2016 11:59 by f4bwj.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 14:03 #10

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
Ok, I see what you have done. I think it is probably better than configuring the router. I presume doing that still maintains an internet connection - your MB1 computer and your remote computer both connect to the internet?
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 14:39 #11

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Yes without problem, my MB1 and remote computer both connect Internet and I'm using Teamviewer to get access to my logbook or to my rotator software (Winrotor) installed on the MB1 from my remote computer.. Concerning my logbook there was a problem as CAT of ExpertSDR2 on my remote computer cannot work with it.
In fact I must keep ExpertSDR2 open on the MB1 but stopped.
I've downloaded Expert Sync and installed it in Windows 10 of the MB1.
In Options -> Manager, I've pressed "connect" button (Server address: 127.0.0.1 here). On the remote computer in Options -> Manager I've put in server address the IP address of the MB1 (e.g. 192.168.0.31 in my case) and pressed "Connect" button too. From now frequency is synchronised between the remote computer and the MB1 in despite ExpertSDR2 on the MB1 is stopped and I get the correct frequency via CAT on my logger. :good:
Last Edit: 16 Aug 2016 14:39 by f4bwj.
The administrator has disabled public write access.

MB1 in remote mode 16 Aug 2016 15:06 #12

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
Sounds good to me. I will write it up in my MB1 User Manual Addendum for the benefit of others.
The administrator has disabled public write access.
The following user(s) said Thank You: Anti

MB1 in remote mode 17 Aug 2016 10:32 #13

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
Dominique - what method are you using to get sound (audio) from the MB1 to the room where your remote computer is located?

Also, are you also transmitting from the remote location - if so, how do you make a microphone input to the MB1?
The administrator has disabled public write access.

MB1 in remote mode 17 Aug 2016 13:30 #14

  • g0cgl
  • g0cgl's Avatar
  • OFFLINE
  • Erik EI4KF / G0CGL
  • Posts: 1192
  • Thank you received: 474
No need to answer - I've done it via Skype. All details are in MB1 section of Forum.
Last Edit: 17 Aug 2016 13:41 by g0cgl.
The administrator has disabled public write access.

MB1 in remote mode 17 Aug 2016 13:55 #15

  • f4bwj
  • f4bwj's Avatar
  • OFFLINE
  • Posts: 61
  • Thank you received: 11
Erik, in fact you don't need Skype or anything else.
You just have to configure ExpertSDR2 on the remote computer as if it was ExpertSDR2 on te MB1.
If you are using PA, for example, you must set PA PTT in Options.
So concerning the way to get sound is very simple, you just need a sound card with a microphone input on the remote computer.
In Option -> Device -> Mic just choose the driver and microphone input you want to use.

In Options -> Sound Card, choose the driver and the Output you want to use to audio Output ans enable it.
By now you can ear your MB1 on your remote computer and you can send your voice to the MB1 for the transmission. ;)

For my part I'm using a creative sound card and I'm using ASIO dirver for the Output to reduce receive latency.
The administrator has disabled public write access.
Time to create page: 0.103 seconds