Welcome, Guest
Username: Password: Remember me

TOPIC: Why so complicated ??? !!

Why so complicated ??? !! 12 Feb 2017 20:07 #1

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Hi there

I have been trying to set up my SUNSDR2 Pro with a RPi to run remotely.
I have been building the image for the RPi a couple of times to start the config from beginning trying to follow the VERY confusing remote setup documentation. No luck so far .

The config Im trying to set up should be the easiest in the world. And still it is a no go.

I have fixed IP-address on the WAN port
I have fixed IP-addresses on the SUNSDR2 pro and RPi - In the same private IP subnet as my WAN-router
I have set up port forwarding in the router for 5050 and 80

Still I cannot remotely reach the radio via RPi-server with the Expert-software nor web-browser.

My profession is a network engineer, so I thought this would be a easy setup following the documentation. But sadly the documentation need some heavy clarification to make it easier for customers to run the EE-devices remotely.

Please help me out here. Im stuck SM0JZT
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 07:52 #2

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
Hi SM0JZT.
Actually, you did everything right.
Let's make some clarifications:
1) Did you make a port-forwarding from a router to RPi3 or SunSDR2 PRO?
You should make a port-forwarding to RPi3.
2) While you connect to the remote server with ExpertRC, in Server address, you should set WAN static-IP of your router.
Please make sure you did that.
3) Please check 5050 port, e.g. here portchecker.co/check
Whether it's open or not?
Роман, Roman
Expert Electronics
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 08:28 #3

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Rome

Answers to below:
1: I have portforwarding to the Rpi
2. I have put the static IP-address of my WAN-port in the remote Client-SW in "Server address"
3. Port 5050 is open all right. Have checked with portchecker.co/check

The "connection status" indicator goes between white and orange flashing.

Is there a way to check whether the RPi "sees" the radio ??
Again. Both the RPi and the radio are on fixed IP-addresses in the same subnet.

/ Tilman
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 08:59 #4

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
OK, let's have a remote session via Teamviewer and SKYPE, we'll connect and check the settings.
We can do that today right now or tomorrow at 12:00 UTC.
If it's OK, please write your ID and password of TeamViewer here: This email address is being protected from spambots. You need JavaScript enabled to view it. and add us in SKYPE: expert_electronics
Роман, Roman
Expert Electronics
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 09:04 #5

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Roman

Thank you so very much for reaching out. Can we do it Thursday this week? Im very busy for the moment. Mondays you know ;-)
/ Tilman
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 09:13 #6

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
Tilman,
No problem for Thursday 12:00 UTC.
Роман, Roman
Expert Electronics
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 09:16 #7

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Great. Thank you so very much.
I will reach out via SKYPE and then we set up Teamviewer. / Tilman
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 13 Feb 2017 15:35 #8

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Rome
Rome wrote:
OK, let's have a remote session via Teamviewer and SKYPE, we'll connect and check the settings.
We can do that today right now or tomorrow at 12:00 UTC.
If it's OK, please write your ID and password of TeamViewer here: This email address is being protected from spambots. You need JavaScript enabled to view it. and add us in SKYPE: expert_electronics
I will not be able to make it this Thursday. I have some customer meetings that I need to attend.

Would friday at 12 UTC work out for you ? / Tilman
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 14 Feb 2017 06:28 #9

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
OK, no problem, let's reschedule on Friday 12:00 UTC
Роман, Roman
Expert Electronics
The administrator has disabled public write access.

Why so complicated ??? !! 16 Feb 2017 09:26 #10

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Rome wrote:
OK, no problem, let's reschedule on Friday 12:00 UTC

Thank you so very much. I will reach out to you then. / Tilman
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 17 Feb 2017 17:47 #11

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Roman and team !!
Thank you so very much for the great support today. I learnt that I had managed to configure all alright.

With this in mind I think that the manual would need some cleaning up. I have the feeling it makes things look more complicated then they are in reality.

Again - Thank you again. / Tilman SM0JZT
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 20 Feb 2017 06:56 #12

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
Hi Tilman,
Thank you for your patience in setting up the remote system.
Regarding the complicated manual, we are open to the suggestions, please name what you consider misleading or overcomplicated we'll try to rethink it.
Роман, Roman
Expert Electronics
The administrator has disabled public write access.

Why so complicated ??? !! 23 Feb 2017 07:28 #13

  • SM0JZT
  • SM0JZT's Avatar
  • OFFLINE
  • Posts: 81
  • Thank you received: 7
Sorry for being a bit slow on my response.
I pretty busy with my daily work and had not much time for to do some additional tests.

I did this morning do a fresh install of a RPi remote server.
All went very smooth and It did work without a glitch. Now knowing how to do.

I think that I simply got trapped by the manual when setting things up. In combination with using the remote client on a PC of mine that seems to block functions (ports ?) needed to run the client.

With this in mind I will spend some time in "rewriting" the manual as I would like to have it. Looking at things "from the outside".
I will pass it on to you to review.

Thank you for a great product. I have been dealing with SDR:s for many years now, and what you have is very promising as a concept for now and the future. The radio for Internet of Things ( IoT ) ;-)

/ Tilman SM0JZT
SM0JZT - Tilman D. Thulesius
Sweden
The administrator has disabled public write access.

Why so complicated ??? !! 27 Feb 2017 07:51 #14

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 1052
  • Thank you received: 529
Hi, Tilman.
Thanks for your time and willingness to improve the manual.
I do appreciate an outside view, it can freshen things up and give the doc another perspective, I'll be waiting for it.

P.S.
Thanks for your kind comments.
The "IoT" reference sounds very daring :good:
Роман, Roman
Expert Electronics
The administrator has disabled public write access.
Time to create page: 0.103 seconds