Welcome, Guest
Username: Password: Remember me
*****PLEASE, CHECK ALL PREVIOUS TOPICS, BEFORE CREATING A NEW ONE! DUPLICATED TOPICS WILL BE DELETED!*****

TOPIC: Linux ExpertSDR2 Performance issues

Linux ExpertSDR2 Performance issues 04 Feb 2020 14:36 #1

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
Hi all!
I am running ExpertSDR2 on Linux and I am having performance issues. I was wondering if anyone has any thoughts on what might be the cause. The screen updates slowly and it gets worse when I try to move the mouse over either the waterfall or panadapter. Sometimes I can find a spot on the top button bar area or off of the program screen and the waterfall will start responding normally. I have tried the current version of the software and the 1.2 version - each respond the same way. I have 4 cores and the software is using 113% of cpu as reported by top. (400% would be all 4 cores in use). Not running out of memory or cpu... thoughts?

HW/SW details:
Machine: Mac Mini
os: Ubuntu 18.04.3 LTS 64-bit
cpu: Intel Core i5-2415M @ 2.3GHZ x4
graphics: intel sandybridge mobile
memory: 16gig
disk: ssd
Lou ki5fty
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 04 Feb 2020 19:43 #2

  • LA3QMA
  • LA3QMA's Avatar
  • OFFLINE
  • Posts: 11
  • Thank you received: 12
I have the same issue.

Using Debian 10 Buster:
Intel® Core™ i7-8550U CPU @ 1.80GHz × 8
Gnome: 3.30.2
Intel® UHD Graphics 620 (Kabylake GT2)
200GB disk
Memory: 16GB
Then the sound is also garbled.

Running 1.3.1 Update 4 of SunSDR DX2
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 04 Feb 2020 19:59 #3

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
yes I have sound issues also
Lou ki5fty
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 04 Feb 2020 20:10 #4

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
I do have the following errors on startup - as seen when I start from shell:

lou@Ham-Mini-Linux:~/Desktop$ ./ExpertSDR2_SunSDR2_1.3.1v4.run
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Failed to extract plugin meta data from '/tmp/.mount_ExpertptqTWV/lib/libdb-5.3.so'"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
void PluginLoader::load(QString&&) "Unknown error"
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
QLayout: Cannot add a null widget to QHBoxLayout/esdrOptions::pL13
SunSDR2::setPreamp(): device isn't opened!

Seems I am having a Jackserver issue and preamp is not starting
Lou ki5fty
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 04 Feb 2020 21:00 #5

  • DK6OV
  • DK6OV's Avatar
  • OFFLINE
  • Posts: 28
  • Thank you received: 10
Hi,
I am also running a SunSDR2 Plus with a Linux-PC. I have the same errors on startup as show above and some more.
But my system is running without the listed problems.

my system is:
CPU: Core i5 Clarkdale i5-660 @ 3.3GHz x 2
Memory: 8 GB
Linux: Arch-Linux (rolling release)
Desk: Cinnamon

The only problem I am dealing with from time to time are underruns in the soundsystem for the VACs.
This then generates ugly pops in the transmitted signal.

Best 73, Dieter DK6OV
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 05 Feb 2020 07:04 #6

  • LA3QMA
  • LA3QMA's Avatar
  • OFFLINE
  • Posts: 11
  • Thank you received: 12
I have the same errors regarding Jack and libdb-5.3.so

Can both of you please send me the results from:
sudo apt list --installed

Then i can compare and see if it's a package missing etc.
Last Edit: 05 Feb 2020 07:06 by LA3QMA. Reason: added info
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 05 Feb 2020 17:17 #7

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
Im traveling for work and wont be back to the computer until the weekend
Lou ki5fty
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 14 Feb 2020 16:48 #8

  • LA3QMA
  • LA3QMA's Avatar
  • OFFLINE
  • Posts: 11
  • Thank you received: 12
This is my list of installed packages:

pastebin.com/QVTdFBeb
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 15 Feb 2020 13:23 #9

  • n1mjf
  • n1mjf's Avatar
  • OFFLINE
  • Posts: 29
  • Thank you received: 4
Awesome to see I'm not the only Arch Linux fan here but you might want to try putting in a hardware accelerated GPU to improve the display update rate. I have a similar set up on my Linux rig that I use my SunSDR2 with but have no issues with display updating. I have an nVidia GTX 970 in it though and SSD. Other than that the specs are just about the same.
Current set up: SunSDR2 DX, HiFi audio, Alpha Delta DX-CC up 20 feet.
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 15 Feb 2020 18:27 #10

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
I don't want to throw hardware at the problem. The PC is a mac mini (which I cant add a gpu) and I run an identical mac mini with windows 10 which has no problems running expertsdr2 and 2 other SDR packages at the same time (Elad-duo and Flex-5000a). So there must be a set of tunables or some problem that needs to be diagnosed.
Lou ki5fty
The administrator has disabled public write access.

Linux ExpertSDR2 Performance issues 15 Feb 2020 20:31 #11

  • n1mjf
  • n1mjf's Avatar
  • OFFLINE
  • Posts: 29
  • Thank you received: 4
I'm not completely sure that the Linux kernel fully supports the Intel HD GPU for acceleration and that might be the core of the issue.
Current set up: SunSDR2 DX, HiFi audio, Alpha Delta DX-CC up 20 feet.
The administrator has disabled public write access.
The following user(s) said Thank You: KI5FTY

Linux ExpertSDR2 Performance issues 17 Feb 2020 05:43 #12

  • KI5FTY
  • KI5FTY's Avatar
  • OFFLINE
  • Posts: 20
  • Thank you received: 2
that makes sense... I will go down that rabbit hole researching it ;-)
Lou ki5fty
The administrator has disabled public write access.
Time to create page: 0.158 seconds