Welcome, Guest
Username: Password: Remember me

TOPIC: Unable to connect via network card with multiple ports

Unable to connect via network card with multiple ports 19 Dec 2021 15:44 #1

  • Smiffy333
  • Smiffy333's Avatar
  • OFFLINE
  • M0MWS
  • Posts: 33
  • Thank you received: 1
Apologies in advance if this topic has been covered.
I have connected direct to the radio via laptop and have set a required ip address.
I plug it into my multiple port network card on my main pc and can see radio via ping command.
But the software wont find it in search.
Is it likely the software is confused over which port to use.
Only received the kit today, so a real newbie here . :(
Last Edit: 19 Dec 2021 15:45 by Smiffy333.
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 19 Dec 2021 15:56 #2

  • danielwee
  • danielwee's Avatar
  • OFFLINE
  • Posts: 209
  • Thank you received: 29
What IP did you set your radio to? (what TCI port is the radio set to)
What is the IP of the client computer?
What OS are you running on?
Are you using EESDR2 or EESDR3? (what TCI port are you using)
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 19 Dec 2021 15:59 #3

  • VK6NX
  • VK6NX's Avatar
  • NOW ONLINE
  • Posts: 335
  • Thank you received: 161
Windows? Linux? Mac? Version? (usually helps to understand the issue better).

Might be (potentially, but not limited) two things: 1. Firewall or/and 2. Network port (where SDR plugged) priority.
For 1 - disable FW and check if any changes. If so, then make sure FW allowing traffic.
For 2 - just analyse what port priorities are currently configured. SDR port is recommended to be on highest position.

Also you have said you configured required IP - is it default, or you have changed it to something else?
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 19 Dec 2021 16:02 #4

  • Smiffy333
  • Smiffy333's Avatar
  • OFFLINE
  • M0MWS
  • Posts: 33
  • Thank you received: 1
Thanks for fast reply,
Radio 192.168.8.2
Port 192.168.8.4
OS W10
EESDR2
TCI port?
SDR ports both set at 50001
Interestingly, I have just tried EESDR3 and it found it and connected first time with no intervention from me
But I would prefer to use current release of EESDR2
Last Edit: 19 Dec 2021 16:31 by Smiffy333.
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 19 Dec 2021 19:34 #5

  • Smiffy333
  • Smiffy333's Avatar
  • OFFLINE
  • M0MWS
  • Posts: 33
  • Thank you received: 1
Thanks for reply,
Port is on highest priority
W10
Have disabled firewall, no different.
As Ping works, I am guessing this is at a lower level in W10, so it looks like its a W10 security problem?
Radio is not on default address.
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 20 Dec 2021 00:11 #6

  • VK6NX
  • VK6NX's Avatar
  • NOW ONLINE
  • Posts: 335
  • Thank you received: 161
For W10 extended setup instructions, search forum for N8SDR's posts, there were few in recent months. (If ESDR3 works and ESDR2 doesn't, it most likely indicates OS blocking or some kind of application conflict. Anyway, it is something very simple, you just need to find out what exactly is the problem source in your case, there we several similar solved posts on forum).

Have a look at FW rules; try to find and eliminate all records regarding ESDR2; then power restart DX, windows and start ESDR2 again - see is this will trigger FW popup to allow ESDR2 traffic. Note, that W10 sometimes continues to apply blocking rules, even FW switched off.

If you have an opportunity, try to use "clean" W10 installation (on separate SSD) and note that ESDR2 can be much more affected by already installed programs (aka remote desktops and so on).
The administrator has disabled public write access.
The following user(s) said Thank You: Rome

Unable to connect via network card with multiple ports 20 Dec 2021 16:47 #7

  • Smiffy333
  • Smiffy333's Avatar
  • OFFLINE
  • M0MWS
  • Posts: 33
  • Thank you received: 1
Ok, thanks for your answer, I have now set it up on two laptops with no problems.
Will remove my intel two port hub and see if a single port solves problem. After that will follow your advice on check his posts.
Thanks for your advice.
The administrator has disabled public write access.

Unable to connect via network card with multiple ports 26 Dec 2021 20:27 #8

  • Smiffy333
  • Smiffy333's Avatar
  • OFFLINE
  • M0MWS
  • Posts: 33
  • Thank you received: 1
Ok, have reinstalled W10 and problem over.
Obviously, as had been mentioned, some program or registry entry has stopped port being accessible to eesdr2
Interesting that eesdr3 works fine.
Thanks to all who answered.
The administrator has disabled public write access.
Time to create page: 0.082 seconds