Добро пожаловать, Гость
Логин: Пароль: Запомнить меня
*****PLEASE, CHECK ALL PREVIOUS TOPICS, BEFORE CREATING A NEW ONE! DUPLICATED TOPICS WILL BE DELETED!*****

ТЕМА: ExpertSDR2 software for MB1

ExpertSDR2 software for MB1 ( Pb power FM modulation with max amplitude 0db 24 Окт 2019 16:53 #106

  • efficace
  • efficace аватар
  • Вне сайта
  • Сообщений: 41
  • Спасибо получено: 1
Hello,
After testing version 1.3.1, I still see a problem with setting the AGC in FM transmission.
in the tab proc / AGC / (activate the maximum amplitude 0 DB) and observe the power in FM modulation!
The power varies a lot from too much with this version.
There may be a problem with the calibration (maximum amplitude at 0 dB)

Normally with the activation of maximum amplitude at 0 dB the power must be stable in fm transmission with modulation

cordially
F4DNK Ingenieur Radar military S/390 IBM
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 25 Окт 2019 07:24 #107

  • Rome
  • Rome аватар
  • Вне сайта
  • Quod Licet Jovi Non Licet Bovi
  • Сообщений: 707
  • Спасибо получено: 294
Hi,
We are aware of the issue, we'll work on it in future releases.
Роман, Roman
Expert Electronics
Администратор запретил публиковать записи гостям.
Спасибо сказали: G4KVT

ExpertSDR2 software for MB1 26 Окт 2019 07:50 #108

  • efficace
  • efficace аватар
  • Вне сайта
  • Сообщений: 41
  • Спасибо получено: 1
Thank you for your response and congratulations for your work, this radio is really the best

cordialy
F4DNK Ingenieur Radar military S/390 IBM
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 29 Нояб 2019 13:22 #109

  • HB9FXU
  • HB9FXU аватар
  • Вне сайта
  • Сообщений: 33
  • Спасибо получено: 3
hi Rome

thank you for your work.

What are the new improvements of the update 3 of expertsdr 2 for MB1 ?

73 de Thomas, HB9FXU
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 02 Дек 2019 10:08 #110

  • HB9FXU
  • HB9FXU аватар
  • Вне сайта
  • Сообщений: 33
  • Спасибо получено: 3
Hi Expert Team

could you please answer my question above regarding Update 3 ?

Thank you and best regards.

73 de Thomas, HB9FXU
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 02 Дек 2019 11:10 #111

  • Rome
  • Rome аватар
  • Вне сайта
  • Quod Licet Jovi Non Licet Bovi
  • Сообщений: 707
  • Спасибо получено: 294
Hi, Tom.
I made a note below the software link: in Update 3 we've improved overall software operation.
In "Update" versions we fix bugs and make improvements that do not require to be mentioned separately, some of them are so technical, it would be hard to explain.
Роман, Roman
Expert Electronics
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 18 Фев 2020 07:11 #112

  • sm4ive
  • sm4ive аватар
  • Сейчас на сайте
  • CW is King VHF-SHF EME
  • Сообщений: 41
  • Спасибо получено: 5
What are the release plan for a newer version?? At nrew Year Vasil mentioned a new version soon, So the 1000 question is Soon is that next year ? Sarkasm
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 03 Март 2020 20:20 #113

  • KV5J
  • KV5J аватар
  • Вне сайта
  • Сообщений: 32
  • Спасибо получено: 3
Roman

We are into the 3rd month of 2020. Is there any advancement with version 1.3.2?

Keith
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 12 Март 2020 10:25 #114

  • R3IIN
  • R3IIN аватар
  • Вне сайта
  • Сообщений: 13
  • Спасибо получено: 4
software ver 1.3.1 Update 4 ! The program has an overestimated signal level on the VAC line ( Cnannel-1 function )
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 19 Июль 2020 15:20 #115

  • KB3Z
  • KB3Z аватар
  • Вне сайта
  • Сообщений: 264
  • Спасибо получено: 5
Roman and all, please see below. This has me totally frustrated.
GM Gentlemen,
I am presently in the sound card section under options.
On the Left it says Sound Card and there is the Enable click on , I can than pick a line which is either MME, WASAPI, WDM-KS. The first one has a little microphone on the left side, and the second underneath that is a set of Headphones on the far left. I would think that the audio should be Virtual Line 1. But now sure which choice to make.
On the Right side is Line out for both Channel 1 and Channel 2. There is a choice for Sound Card and also Wave File. Honestly I do not know what the Wave File is for.\
I would assume that the sound card would be for Line 2. And of course the choices are MME, WASAPI or WDM-KS.
My N1MM works just fine so that is not an issue. But when I try to monitor on MMTTY, I don't receive one thing.
In the Book it shows line 1 for receive and line 2 for transmit.
Any help would be greatly appreciated.
Mark Griffin, KB3Z
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 19 Июль 2020 18:50 #116

  • g0cgl
  • g0cgl аватар
  • Сейчас на сайте
  • Erik EI4KF / G0CGL
  • Сообщений: 885
  • Спасибо получено: 351
Mark, bear with me. What do you mean by 'monitor on MMTTY'? Is this a monitor of your transmit or do you mean receive ie you are not receiving RTTY signals?

Either way, sound card is irrelevant unless your audio path is hardware defined. But you then mention a virtual line so I assume you are using VAC.

So, if you mean no reception of the RTTY signal and you are using VAC, then MMTTY is not set to receive on the correct VAC line. It is no different to any other data receiving software e.g N1MM on RTTY or WSJTx on FT8. The setting is exactly the same. Yesterday I invited you to follow the UMA. But clearly you missed that advice for there is no reference to sound card in the MMTTY section.

Let's have a little tutorial. I know but you did say 'any help'. ESDR2 requires a specific setting that you probably already have since you mention N1MM.

rtty1.png


The upper limit of the bandwidth is arbitary. The offset of 2200hz is necessary or else if you are trying to find a sigal from a DX Spot you will be off frequency. ESDR2 has of course got to be in DIGL mode with a filter setting of your choice (but not too narrow).

MMTTY requires audio and PTT. For the latter, in 'Set Up MMTTY' go to the TX tab and set PTT & FSK to COM 10 (if you have followed the UMA and have PTT in ESDR2 set to COM 9).
For audio go to the sound card tab and place check marks in the usual places: RX is line 1 and TX is Line 2.

rtty2.png


Note that the layout of this tab varies between MMTTY versions but the principle is always the same.

'OK' out to the main GUI and you will be receiving. At the time of writing I cannot find a RTTY signal but the picture shows normal reception.

rtty3.png


If you send a macro or press TX for the diddle, ESDR2 will respond by going into transmit with the correct tones

rtty4.png




If while transmitting you want to hear those tones in headphones or speaker, go to the down arrow to the right of MON in the computer GUI and set to on 'Always enabled MON in SSB for VAC'
Последнее редактирование: 19 Июль 2020 18:57 от g0cgl.
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 19 Июль 2020 21:12 #117

  • KB3Z
  • KB3Z аватар
  • Вне сайта
  • Сообщений: 264
  • Спасибо получено: 5
Erik,
I cannot receive anything at all. Either in MMTTY or WSJT.
When I load WSJT and use Vac 1 for receive and Vac 2 for transmit I get an error message from the program saying that Error in Sound Input.
Under VAC in EESDR2 I have the following settings, RX WDM-KS Line Out Virtual Cable 1. For TX I have WMD-KS:Line 2.
Also when I open up the VAC under Cable 1 I have zero RC Streams but 1 PB Stream.
For Cable 2 I have 1 RC Stream but 0 PB Stream.
Under the Sound Car Option on the left sound card settings I don't know what to have for the Microphone or the headphone selection. Under Sound card on the right side for channel 1 I presently have WDM-KS Line Out Cable 1.
I have no problem operating N1MM on either CW or SSB. I can also run CW Skimmer with no issues.
It's just the digital modes that are giving me the problems.
Under the Device/TX I have the same entry that you have for DIGL.
I'm at a complete loss.
Though there is a part of me that says that either the problem is with the VAC Program or Vac/Sound card settings on the MB1.
I hope I have explained what I am seeing with my MB1.
Mark
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 19 Июль 2020 21:24 #118

  • KB3Z
  • KB3Z аватар
  • Вне сайта
  • Сообщений: 264
  • Спасибо получено: 5
Erik,
I just thought about this. When I hit the System Audio settings it brings up the Windows Settings.
Under Playback it has Virtual Audio Cable Line 10 with a green mark on it.
And under Recording it has Microphone PNP USB Sound Device with a green mark on it.
Does that play a bearing on this?
Mark
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 20 Июль 2020 01:25 #119

  • KB3Z
  • KB3Z аватар
  • Вне сайта
  • Сообщений: 264
  • Спасибо получено: 5
Erik,
I am currently using VAC Version 4.60. The operating system is Windows 10 Home Version 1909 OS Build 16363.959.
Mark
Администратор запретил публиковать записи гостям.

ExpertSDR2 software for MB1 20 Июль 2020 08:12 #120

  • g0cgl
  • g0cgl аватар
  • Сейчас на сайте
  • Erik EI4KF / G0CGL
  • Сообщений: 885
  • Спасибо получено: 351
Ok Mark, from a distance it is hard to diagnose. What I say next may miss the real cause because I can only comment on generalities.

I do not like to see reference to sound card in these types of problems. Forget sound card, those settings are for other things. I think there needs to be a tutorial on the valid uses of sound card and line out. For now disable them - uncheck their enable buttons.

In ESDR2, VAC should be like this except that your RX gain and TX gain maybe zero or at other levels. Right now set them both to zero.

VAC1.png


Windows sound system has some bearing on VAC. The audio path does not use this route provding that in the VAC Control Panel you have not checked 'Volume Control' for either of the VAC lines used by MMTTY. The Golden Rules for Windows sound system:

Microphone access must be on (Windows considers every digital application to be a microphone). In Windows Settings, Microphone page, ensure it is on and then scroll down to 'Allow Desktop Apps to Access Microphone' and ensure that is on.

In Windows Settings, go to the Sound page. Ouput Device should be your Windows Speakers, whatever you listen to computer audio with. Input device should be your Windows microphone. If you do not have one, set this to a dummy entry, anything other than a VAC Line. Nothing on this screen must point to VAC. With your digital apps of your choice open, scroll down to App Volume Device Preferences and for MMTTY set as below:

VAC2.png


Incidentally, this work is largely 'set and forget', no need to revisit unless you later install a new program with audio that might set this stuff to default.

Back on the previous Sound page, on right hand side click Sound Control Panel. Now nothing here needs their properties setting but the two Windows devices we just set up, Speaker for Windows audio and Windows Microphone (or whatever was picked as a dummy) must be set to Default Device and Default Communication Device. There will be Speakers on the Playback tab and microphone on the Recording tab. This is so that any computer audio, real or noise generated by computer activity, stays in the Windows audio system and is not allowed to affect digital or worse, get broadcast.

Close all programs and reboot. Relaunch ESDR2 and then MMTTY and tell me the status of MMTTY TX and RX.

Regarding VAC - there is a new version 4.64 that you can get by amending your download link sent to you when you registered. But this is not important right now. If you do later install it, you will need to set again the Default Device and Default Communication Device in the Windows Sound Control Panel.

Just for completeness, irrelevant to your MMTTY issue because you have the Muzychenko VAC, there are the VAC Line properties. These do not matter unless you use a different virtual audio cable software, like VB Cable/Voicemeeter Banana, or you have Volume Control enabled in the VAC Control Panel (you should not do that except if there is too much audio gain for WSJTx/JTDX and you need to reduce it more than can be done in ESDR2 (a very rare senario)). Then the following settings apply:

VAC3.png
Последнее редактирование: 20 Июль 2020 08:42 от g0cgl.
Администратор запретил публиковать записи гостям.
Спасибо сказали: Rome
Время создания страницы: 0.224 секунд