Welcome, Guest
Username: Password: Remember me
This category was created to discuss various questions and topics regarding ExpertSDR2 operation.

TOPIC: E-coder stops Windows screen sleep

E-coder stops Windows screen sleep 12 Jan 2021 18:32 #1

  • VE1GPY
  • VE1GPY's Avatar
  • OFFLINE
  • Posts: 9
  • Thank you received: 1
If my E-coder Plus is plugged in, Windows 10 does not put my display(s) to sleep. I was trying to figure out why my monitors were staying on all night and wouldn’t enter sleep or screen saver modes. Searching on-line, I found that USB Human Interface Devices sometimes interfere with Windows power management’s ability to turn off the displays. Sure enough, if I unplugged the E-coder everything returned to normal. With the E-coder plugged in, the displays never sleep.

I’ve:
(a). Turned off ‘USB selective suspend’ in Windows Power Options advanced settings; and
(b). Run a “powercfg -requests” Windows command which does not show any ‘System’ device that is interrupting Power sleep mode. So there is nothing to bypass in powercfg.

Has anyone else seen this? Is there any way to restore normal display sleep/screen saver operation?

Operating System is: Windows 10 Home v2004, build 19041.685
ExpertSDR2 version: 1.3.1 Update 8


Thanks, and 73,
Sheldon, VE1GPY/VE1SL
The administrator has disabled public write access.

E-coder stops Windows screen sleep 17 Jan 2021 17:14 #2

  • VE1GPY
  • VE1GPY's Avatar
  • OFFLINE
  • Posts: 9
  • Thank you received: 1
[cross-posted on the threads for both problems]

I’ve developed a work-around for the two problems I was having with ExpertSDR2.

To recap, my issues were:
  1. When I open an RX2 or BP window on a second monitor, ESDR2 hangs the next time I try to use it.
  2. My E-Coder interferes with Windows power management and prevents displays from sleeping.

To work around these problems, I created the following command file and now use it to start ESDR2. It disables the E-Coder Windows device when ESDR2 is not running and it always restores ESDR2 settings from a known good copy.
::
:: Launch_ExpertSDR2.cmd
::
:: This command file starts the ExpertSDR2 program, after first:
::  - restoring the ExpertSDR2 settings to a known good state, and`
::  - enabling the E-coder device.
::
:: The command file disables the E-coder device before exiting to
:: prevent the E-coder from messing with Windows power management.
::
 
set EXE_DIR=C:\Program Files\ExpertElectronics\ExpertSDR2 SunSDR2DX
set USER_DIR=C:\Users\<your-user-name>\AppData\Local\Expert Electronics
set DEVICE_ID=USB\VID_1FC9^&PID_0003\EE-EP-01____
 
cd %USER_DIR%
 
:: Use Plug and Play Utility to enable the E-coder device.
pnputil /enable-device "%DEVICE_ID%"
 
:: Restore the ExpertSDR2 directory from the lifeboat copy.
robocopy "%USER_DIR%\ExpertSDR2 - lifeboat" "%USER_DIR%\ExpertSDR2" /MIR /XD voice /XD wave
if %ERRORLEVEL% GTR 1 GOTO END
 
:: Launch the ExpertSDR2 application.
"%EXE_DIR%\ExpertSDR2.exe" || GOTO END
 
:END
:: Use Plug and Play Utility to disable the E-coder device again.
pnputil /disable-device "%DEVICE_ID%"
EXIT

However, this does mean If I make changes to ESDR2 settings that I want to keep, I have to refresh the saved copy of the ExpertSDR2 directory.

73,
Sheldon, VE1GPY/VE1SL
The administrator has disabled public write access.
The following user(s) said Thank You: Rome
Time to create page: 0.068 seconds