Welcome, Guest
Username: Password: Remember me
*****PLEASE, CHECK ALL PREVIOUS TOPICS, BEFORE CREATING A NEW ONE! DUPLICATED TOPICS WILL BE DELETED!*****

TOPIC: VPN -Remote station

VPN -Remote station 09 Jun 2018 10:34 #1

Dear All,
I have to use my SunSdr2Pro remotely. So I decided to set up a VPN to use the Full EESDR (I need to TX too).
So, yesterday I set up a new VPN via my router (I have 100Mbs DL and 20Mbs UP).
The remote station works with some annoying lags, but more or less seems to work.
I have seen that that it uses up 14Mbs. There is a chance to reduce the band of some Mbs? I neet to use my RIG remotely.

Best 73!
Giulio IZ3EAW
Cattura.jpg
The administrator has disabled public write access.

VPN -Remote station 09 Jun 2018 11:35 #2

  • Rome
  • Rome's Avatar
  • OFFLINE
  • Quod Licet Jovi Non Licet Bovi
  • Posts: 287
  • Thank you received: 139
Hi, Giulio.
Try to lower the sample rate, it should help.
In the new software version ESDR2 1.3 we'll try to implement new firmware which works better with an internal WLAN unit.
Роман, Roman
Expert Electronics
The administrator has disabled public write access.
The following user(s) said Thank You: IZ3EAW

VPN -Remote station 09 Jun 2018 11:45 #3

  • sv9djo
  • sv9djo's Avatar
  • OFFLINE
  • Posts: 8
  • Thank you received: 6
Hi Giulio ,
The main issue is the latency of connection between your edges of VPN and should be less than 13msec ,you can ping the sunsdr via VPN to see the response time ,best results is with fiber optics connection.In order to reduce bandwidth just lower the sample rate and should get about 2mbit/sec.
The best way is thru wifi link if is near by.
take look at #3 for some details!!
eesdr.com/en/forum-en/remote-control/7277-sunsdr2-pro-info#8264

The fact is in future release of remote control software with TX capabilities is the round trip delay which is mentioned from Vassily should be about 500msec which is ok for blabla but to useless for contesting or DXing
The administrator has disabled public write access.
The following user(s) said Thank You: IZ3EAW

VPN -Remote station 09 Jun 2018 19:01 #4

Hi Giulio,

I'm using remote over internet my SunSDR2 Pro, usually DX work and CW major contests without any issues.
You have enough bandwidth, don't use a VPN solution, it will slow your processing flow, use a direct internet connection and use port forwarding on your router. Also try to use a good CAT6/7 ethernet cable instead of WiFi, try to avoid anything that can add latency. If you have under 7-10ms latency and 20 Mbps upload bandwidth you should be ok.
The administrator has disabled public write access.
The following user(s) said Thank You: IZ3EAW

VPN -Remote station 09 Jun 2018 20:15 #5

Thank you all for the quick reply. I use WiFi because I am using my smartphone in 4G+ (dl 23Mbs, ul 12MbS).
I tried with a samplerate of 39k, but consumes less Mbs, few.
Anyway, I wanna try Aureliandan setting.
Giulio IZ3EAW
1.jpg


2.jpg


3.jpg
Last Edit: 09 Jun 2018 20:17 by IZ3EAW.
The administrator has disabled public write access.

VPN -Remote station 09 Jun 2018 21:23 #6

Hello,
Which port do I have to open? 50001?
Do I have to forward as tcp/ip or UDP?
Tnx.
Giulio
The administrator has disabled public write access.

VPN -Remote station 10 Jun 2018 10:57 #7

You will need to open TCP port for RX1, RX2 and BS ports, usually these are 50001, 50002, 50003 but you can change them if you want. If you use only RX1 then only one port for this receiver and BS port if you use it.
You cannot use UDP over internet but anyway you can choose TCP/UDP or Both on your router.
You will have to know your remote IP as ExpertSDR2 does not know yet about FQD Names like mydomain.com. If you don't have a fix IP, you will have to check it, my provider for example, change my IP once per month so I have to reconfigure ExpertSDR2 everytime.
I understand that will be updates to solve this issue but ... nothing yet
The administrator has disabled public write access.
The following user(s) said Thank You: IZ3EAW

VPN -Remote station 12 Jun 2018 20:48 #8

  • iw7dmh
  • iw7dmh's Avatar
  • OFFLINE
  • Posts: 113
  • Thank you received: 63
Hello,
I am interested in this subject and I did some attempts togheter with Giulio. We configured the router enabling port forwarding for ports 50001, 50002 and 50003 from router to SunSDR2-Pro local address (192.168.1.200) and backwards.
But we still can't connect the rig from Internet although we are pretty sure every configuration rule is fine.
We tested one of this rule using the IP Address of another intranet PC and we were able to connect it using a simple telnet.
So now I have the following questions:
1- what is the BS you mentioned in the previous post?
2- how can Expert software discover a rig over the net?
3- what is the difference between the IP in rectangle A and the IP in rectangle B (Please see attached pic)
4- how they have to be set when one want to use the rig in internet (like we are going to do?)

Thank you very much an 73'
Enzo, iw7dmh

Attachments:
Last Edit: 12 Jun 2018 20:53 by iw7dmh.
The administrator has disabled public write access.

VPN -Remote station 12 Jun 2018 21:13 #9

A - should have the IP WAN address of the remote location, where you have your SunSDR2, This IP is from your internet provider and is visible in Internet, should be something like 81.123.192.66 (192.168.2.XXX is an IP from your internal network)
So for example if you have your PC in Rome and your SunSDR2 PRO in Napoli, you should know the WAN IP address allocated by your provider in Napoli and this IP should be entered in ExpertSDR PC in Rome (Box A).
192.168.1.200 is the IP address of SunSDR box in your internal network.
BS - button turning on the spectrum analyzer in the whole receiving range 0 to 62MHz (broadband scope).
Box B is used when you want to change the IP of your SunSDR2.for example if you want to have it 192.168.1.15 for example
Last Edit: 12 Jun 2018 21:14 by aureliandan.
The administrator has disabled public write access.

VPN -Remote station 13 Jun 2018 08:06 #10

  • iw7dmh
  • iw7dmh's Avatar
  • OFFLINE
  • Posts: 113
  • Thank you received: 63
Hi Aureliadan,
thank you very much for your answer. It seems we did the same config you wrote. To make things clearer I draw the schematic of our tests.
As you can see, we enabled the three ports to and from the SunSDR-Pro2 (192.168.1.200) and we weren't able to connect the rig from internet. We used the public address of the router.
Then we redirect the port 50001 to another PC with a telnet server enabled and it worked fine.
I think is it a good test to find out rules on the router that aren't properly configured. Do you think it so?
73' Enzo
iw7dmh

test.png
The administrator has disabled public write access.

VPN -Remote station 13 Jun 2018 09:25 #11

Ok, first of all you should test the local functionality. Are you able to connect to SunSDR2 on the local network, do you have a response from ping 192.168.1.200 command ?
By default, SunSDR2 is configured with 192.168.16.200. If you didn't change that IP to 192.168.1.200, it won't work. This is a video explaining how to change SunSDR2 default IP address:
Next, as a best practice, the IP you assign to SunSDR2 should not be part of a DHCP IP pool address, if you have DHCP enabled on your router, choose a limited interval for DHCP IPs pool like 192.168.1.100 - 250 and give SunSDR2 an IP out of this pool 192.168.1.50 for example. This way you will be sure that SunSDR2 will have the same fixed IP address and there are no conflicts with other devices on the local network.
The administrator has disabled public write access.

VPN -Remote station 13 Jun 2018 16:53 #12

  • sv9djo
  • sv9djo's Avatar
  • OFFLINE
  • Posts: 8
  • Thank you received: 6
I think that the problem is on default gateway , probably if your router is running in the same subnet with sdr 192.168.16.1 for example or 192.168.16.254 should work. The fact is that you can't change default gateway on sunsdr2 pro from menu if you are moving to other than 192.168.16.x subnet.
port forwarding is not working when that NATed devices haven't the right gateway.
The administrator has disabled public write access.
The following user(s) said Thank You: iw7dmh
Time to create page: 0.252 seconds